Ceci est une ancienne révision du document !
Table des matières
Identification de la classe d'adresse (RFC 791)
Les Classes
Il s'agira d'identifier la classe d'adresse :
- Les adresses de Classe A commencent par 0xxx en binaire, ou 0 à 127 en décimal.
- Les adresses de Classe B commencent par 10xx en binaire, ou 128 à 191 en décimal.
- Les adresses de Classe C commencent par 110x en binaire, ou 192 à 223 en décimal.
- Les adresses de Classe D commencent par 1110 en binaire, ou 224 à 239 en décimal.
- Les adresses de Classe E commencent par 1111 en binaire, ou 240 à 255 en décimal.
Notes sur les Classes d'adresses :
- Seules les adresses de Classes A, B et C sont assignables à des interfaces (adresse d'Unicast)
- La classe D est utilisée pour des adresses de Multicast (adresse unique identifiant de nombreuses destinations)
- La classe E est utilisée pour des besoins futurs ou des objectifs scientifiques
Adresses spécifiques :
- Les adresses commençant de 127.0.0.0 à 127.255.255.255 sont réservées pour le bouclage (loopback)
- Adresses privées non routables vers l'Internet sont (RFC 1918) :
- Pour la classe A : de 10.0.0.0 à 10.255.255.255
- Pour la classe B : de 172.16.0.0 à 172.31.255.255
- Pour la classe C : de 192.168.0.0 à 192.168.255.255
Distinction de la partie réseau de la partie hôte
Par défaut :
- La partie réseau des adresses de Classe A portera sur le premier octets et la partie hôte sur les trois derniers (2^24 = 16 777 216 hôtes possibles par réseau)
- La partie réseau des adresses de Classe B portera sur les deux premiers octets et la partie hôte sur les deux derniers (2^16 = 65 536 hôtes possibles par réseau)
- La partie réseau des adresses de Classe C portera sur les trois premiers octets et la partie hôte sur le dernier (2^8 = 256 hôtes possibles par réseau)
Utilisation d'un masque (RFC 950)
Un masque va préciser de manière certaine dans quel réseau se trouve un adresse IP et en conséquence :
- L'adresse du réseau (appelée aussi numéro de réseau, non assignable)
- L'adresse de broadcast (adresse visant toutes les destinations, non assignable)
- La plage d'adresses utilisables (de la première à la dernière en dehors des adresses précitées)
Un masque sera une suite de 32 bits divisée en 4 octets pointés composée uniquement d'abord d'une suite de 1 et, après, d'une suite de 0. La notation est aussi décimale pointée. Toutefois, on trouvera une autre notation dite CIDR [3] qui représente le nombre de bits pris par la partie réseau du masque.
1/ Masque par défaut
Le nombre d'hôte possible obtenus ci-dessus correspond à l'application d'un masque par défaut sur type de classe d'adresse :
Le masque par défaut des adresses de Classe A est 255.0.0.0 ou /8 Le masque par défaut des adresses de Classe B est 255.255.0.0 ou /16 Le masque par défaut des adresses de Classe C est 255.255.255.0 ou /24
Méthode par calcul binaire
L'adresse du réseau, l'adresse de broadcast et la plage d'adresses utilisables peut être obtenu à partir d'un calcul booléen de type ET ou la conjonction logique (une proposition est vraie lorsque les deux termes sont tous les deux vrais) :
a. Obtenir l'adresse du réseau :
Pour l'adresse IP 140.159.125.25, adresse de classe B à laquelle on applique un masque par défaut de 255.255.0.0 :
10001100.10011111.01111101.00011001 140.159.125.25 11111111.11111111.00000000.00000000 255.255.0.0
10001100.10011111.00000000.00000000 140.159.0.0
L'adresse du réseau est donc 140.159.0.0
b. Obtenir l'adresse de broadcast :
On va remplacer les bits de valeur 0 de la partie hôte du résultat obtenu pour l'adresse de réseau par des bits de valeur 1 :
10001100. 10011111. 00000000. 00000000 140.159.0.0 par : 10001100. 10011111. 11111111. 11111111 140.159.255.255
c. Obtenir la plage d'adresses de ce réseau :
La plage d'adresse du réseau sera comprise entre la première adresse utilisable et la dernière utilisable, autrement dit, celle qui suit l'adresse du réseau et celle qui précède l'adresse de broadcast :
De 10001100. 10011111. 00000000. 00000001 140.159.0.1 A 10001100. 10011111. 11111111. 11111110 140.159.255.254

