Ceci est une ancienne révision du document !
Table des matières
Excel
Quelques formules
Pour afficher 10 puissance 4 soit 1000 :
=PUISSANCE(10;4)
Pour arrondir un chiffre à l'entier supérieur. Ci-dessous 1,5 arrondi à 2 :
=ARRONDI.SUP(1.5;0)
Pour arrondir 1,46 à 1,5 :
=ARRONDI.SUP(1.46;1)
Pour arrondir un chiffre à l'entier inférieur. Ci-dessous 1,5 arrondi à 1 :
=ARRONDI.INF(1.5;0)
Afficher une durée en secondes sous le format hh:mm:ss (53:12:45 : pour 53 heures, 12 minutes et 45 secondes) :
=A1/(3600*24)
- A1 étant la valeur exprimée en secondes
- Pour le format aller dans : Format → Cellule → Nombre → Heure → 37:30:55
Concaténer des cellules
Concaténer les cellules A1 à C1
| A | B | C | D | |
|---|---|---|---|---|
| 1 | text1 | text2 | text3 | =A1&A2&A3 |
Ou bien :
| A | B | C | D | |
|---|---|---|---|---|
| 1 | text1 | text2 | text3 | =CONCATENER(A2;B2;C2) |
Résultat :
| A | B | C | D | |
|---|---|---|---|---|
| 1 | text1 | text2 | text3 | text1text2text3 |
On peut insérer également du texte entre les cellules concaténées
On insère ici “@” :
| A | B | C | |
|---|---|---|---|
| 1 | user | domaine.com | =A1&“@”&B1 |
Ou bien :
| A | B | C | |
|---|---|---|---|
| 1 | user | domaine.com | =CONCATENER(A1;“@”;B1) |
Résultat :
| A | B | C | |
|---|---|---|---|
| 1 | user | domaine.com | user@domaine.com |
Créer une liste de choix
Créer une liste de choix comme illustrée ci-dessous :
Selectionner une ou plusieurs cellules, puis Données → Validation…. Puis configuré comme illustré ci-dessous :
Liste de choix conditionnel
L'idée est de proposer une liste de choix différente dans la cellule B1 selon le choix effectuée sur la cellule précédente A1 :
Exemple :
- En cellule A1, je souhaite avoir le choix entre LINUX et WINDOWS
- Si j'ai choisi LINUX je souhaite uniquement avoir les choix suivants en B1 : Debian;Redhat;Suse
- Si j'ai choisi WINDOWS je souhaite uniquement avoir les choix suivants en B1 : Windows 2003 server; Windows 2008 Server
Pour réaliser cette choix selectif, la procédure est la suivantes :
- En cellule A1, créer votre liste de choix comme décrit ci-dessus
- Dans une autre feuille créer la tableau suivant :
| WINDOWS | LINUX |
|---|---|
| Windows 2003 Server | Debian |
| Windows 2008 Server | RedHat |
| Suse |
- tetr
Etre alerté des doublons dans une colonne
Pour être alerté par un texte affiché en rouge lorsque le même texte existe déjà dans la colonne :
- Sélectionner toute la colonne A
- Aller dans Format → Mise en forme conditionnelle…
- Dans Condition 1 choisir La formule est
- Saisir la formule :
=NB.SI(A:A;A1)>1(Par exemple pour la colonne B la formule serait :=NB.SI(B:B;B1)>1) - Pour terminer choisir la couleur de la cellule ou du texte pour être alerté en cliquant sur Format…
Recherche de valeur
Voici ce que fait Excel quand il exécute la formule située en B2 :
- 1° : Excel consulte la cellule A2 (cellule_lue) et y lit la valeur 2.
- 2° : Excel consulte le tableau qui s'étend de la cellule G2 à la cellule I4. Il y trouve la valeur 2 lue précédemment.
- 3° : Excel écrit dans la cellule B2 la valeur “bananes” située dans la deuxième colonne du tableau.
Quelques liens
Fichiers Excel à télécharger
- Calculateur de stockage : calculateur_de_stockage.xls





